Strona Główna Unixy.pl
Internetowe forum na temat systemów GNU/Linux Unix

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy  StatystykiStatystyki
RejestracjaRejestracja  ZalogujZaloguj  DownloadDownload
 Ogłoszenie 
Strona korzysta z plików cookies w celu realizacji usług (logowanie do konta itp.). Możesz określić warunki przechowywania lub dostępu do plików cookies w Twojej przeglądarce.

Poprzedni temat «» Następny temat
Openvpn i utrata 30-40% pasma
Autor Wiadomość
marcinus 

JID: zygfrydos(na)gmail(kropka)com
Pomógł: 2 razy
Dołączył: 12 Cze 2005
Posty: 118
Wysłany: 2008-10-29, 23:33   Openvpn i utrata 30-40% pasma

Mam skonfigurowanego openvpn-a, jako serwer linuks, jako klient windows i trace 30-40% pasma w stosunku do rzeczywistego interfejsu. Jest to normalne ? Ma ktoś to skonfigurowane?
Wprawdzie mam szyfrowanie 1024 bitowe ale czy była by dzięki temu taka strata ?

dzięki za pomoc, pozdrawiam
_________________
Mail / Jabber: [email protected]
Home page: http://zygfryd.platinum.linux.pl
 
     
kriks 
Administrator

JID: [email protected]
Pomógł: 15 razy
Dołączył: 07 Cze 2005
Posty: 609
Wysłany: 2008-10-31, 19:19   

Też mam 1024, u mnie to 10-20 %
_________________
jesteś nowy, przeczytaj to..
 
     
marcinus 

JID: zygfrydos(na)gmail(kropka)com
Pomógł: 2 razy
Dołączył: 12 Cze 2005
Posty: 118
Wysłany: 2008-11-01, 18:49   

A mogłbyś wystawić openvpn.conf ?, abym mógł porównać ?
_________________
Mail / Jabber: [email protected]
Home page: http://zygfryd.platinum.linux.pl
 
     
Xed 
Administrator

Pomógł: 18 razy
Dołączył: 07 Cze 2005
Posty: 567
Wysłany: 2008-11-01, 20:57   

http://www.zeroshell.net/...f3677e54d799c6a
Kod:

Don't worry max bandwidth of OpenVPN is limited only by CPU performances.
(...)
here is not a fixed limit. For example with the Pentium 4 2GHz Processors I get 160Mbit/s with netperf.


u mnie testy na:
1. dwa komp. w tym samym segmencie sieci
a) cpu 800mhz, 100Mbit
b) cpu 1.6ghz, 100Mbit
(oba na win xp)

2. osiągi (przez tunel openvpn oczywiście), cifs:
a) ok 950kB/s
b) 1800-2400kB/s

(...)
cipher AES-256-CBC
comp-lzo
tun-mtu 1500
...dh1024.pem ;)
 
     
kriks 
Administrator

JID: [email protected]
Pomógł: 15 razy
Dołączył: 07 Cze 2005
Posty: 609
Wysłany: 2008-11-03, 19:26   

marcinus napisał/a:
A mogłbyś wystawić openvpn.conf ?, abym mógł porównać ?


mój openvpn.conf na kliencie windowsowym

Kod:
dev tun
tun-mtu 1500
remote mojeip
ns-cert-type server

client
comp-lzo

ping 15
ping-restart 45
ping-timer-rem
persist-tun
persist-key
verb 4
tls-client
ca server.crt
cert client.crt
key client.key
_________________
jesteś nowy, przeczytaj to..
Ostatnio zmieniony przez kriks 2008-11-03, 19:27, w całości zmieniany 1 raz  
 
     
marcinus 

JID: zygfrydos(na)gmail(kropka)com
Pomógł: 2 razy
Dołączył: 12 Cze 2005
Posty: 118
Wysłany: 2008-11-05, 22:41   

Dziękuje za pomoc. Okazało się, że brak ustawienia MTU to powodował, teraz jest spadek ok 10-18%. Nie bałem się o wydajność sprzętu. Bo to połączenie jest między serwerem na linuksie gdzie tap0 jest połączony w bridge z dwoma innymi interfejsami, dodatkowo mój ISP nie jest za pewny (ograniczenie 1Mb po stronie klienta), dlatego stawiałem bardziej na słaby algorytm openvpn, czy też problemy na łączu lub mostku. Na szczęście okazało się ze to tylko MTU. Teraz mój zasób montowany po sambie pięknie śmiga, a pomiary wykonałem dzięki porównaniu prędkości i ilości przesłanych danych na wirtualnym i prawdziwym interfejsie po stronie klienta.

Z góry dziękuje i pozdrawiam.
_________________
Mail / Jabber: [email protected]
Home page: http://zygfryd.platinum.linux.pl
 
     
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group