Strona Główna Unixy.pl
Internetowe forum na temat systemów GNU/Linux Unix

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy  StatystykiStatystyki
RejestracjaRejestracja  ZalogujZaloguj  DownloadDownload
 Ogłoszenie 
Strona korzysta z plików cookies w celu realizacji usług (logowanie do konta itp.). Możesz określić warunki przechowywania lub dostępu do plików cookies w Twojej przeglądarce.

Poprzedni temat «» Następny temat
ClamAV-0.95...rpm problem z rpm -Uhv clam*rpm
Autor Wiadomość
SP1LOP 
Emeryt-Inwalida


Dołączył: 25 Lis 2007
Posty: 9
Wysłany: 2009-04-08, 14:57   ClamAV-0.95...rpm problem z rpm -Uhv clam*rpm

Witam...
Używam RH EL3

Próbuje zrobić update z ClamAV-0.95 ale mam problemy, otrzymuje komunikat, że system nie widzi libclamav.so.5 a mam je z poprzedniej instalacji (0.94.2-1)...
Czy mogę poprosić o pomoc...
_________________
Janusz Przybylski - SP1LOP
----------------------------------------------------------
Admin Polskiej Sieci AmprNet [44.165/16]
Ostatnio zmieniony przez SP1LOP 2009-04-08, 14:59, w całości zmieniany 1 raz  
 
     
Maciek_Rutecki 
Administrator

JID: [email protected]
Pomógł: 39 razy
Dołączył: 07 Cze 2005
Posty: 2959
Wysłany: 2009-04-08, 20:28   

Nie może sie zaktualizować do 0.95, czy po aktualizacji do 0.95 nie chce się uruchomić?

Jeśli to drugie, to jako root wydaj polecenie:

Kod:
ldconfig


jeśli faktycznie szukana biblioteka istnieje.

I pokaż komunikat błędu po uruchomieniu clamava, być może szuka biblioteki nie tam gdzie jest (np. w /lib choć jest w /usr/lib), co dosyć typowe w RedHat.

Dla pewności: instalacja z pakietów RPM?

PS. Szczeciński AmprNet? :)
_________________
Maciek
http://www.maciek.unixy.pl
 
     
Xed 
Administrator

Pomógł: 18 razy
Dołączył: 07 Cze 2005
Posty: 567
Wysłany: 2009-04-08, 21:45   

Maciek_Rutecki napisał/a:


PS. Szczeciński AmprNet? :)

że się tak wtrące:
http://www.qrz.com/db/sp1lop
 
     
SP1LOP 
Emeryt-Inwalida


Dołączył: 25 Lis 2007
Posty: 9
Wysłany: 2009-04-15, 14:25   

Maciek_Rutecki napisał/a:
Nie może sie zaktualizować do 0.95, czy po aktualizacji do 0.95 nie chce się uruchomić?
Kod:
ldconfig


Problem z zainstalowaniem czyli:

[[email protected] ClamAV-0.95-1]# rpm -Uhv clam*rpm
ostrzeżenie: clamav-0.95-1.el3.rf.i386.rpm: Sygnatura V3 DSA: NOKEY, key ID 6b8d79e6
błąd: Niespełnione zależności:
libclamav.so.5 jest wymagany przez (zainstalowany) clamav-milter-0.94.2-1.el3.rf
libclamav.so.5(CLAMAV_PRIVATE) jest wymagany przez (zainstalowany) clamav-milter-0.94.2-1.el3.rf
libclamav.so.5(CLAMAV_PUBLIC) jest wymagany przez (zainstalowany) clamav-milter-0.94.2-1.el3.rf
libclamunrar.so.5 jest wymagany przez (zainstalowany) clamav-milter-0.94.2-1.el3.rf
libclamunrar_iface.so.5 jest wymagany przez (zainstalowany) clamav-milter-0.94.2-1.el3.rf
clamd = 0.94.2-1.el3.rf jest wymagany przez (zainstalowany) clamav-milter-0.94.2-1.el3.rf
[[email protected] ClamAV-0.95-1]#


A 0.94.2 mam aktualnie czynne i działające....

Maciek_Rutecki napisał/a:
I pokaż komunikat błędu po uruchomieniu clamava, być może szuka biblioteki nie tam gdzie jest (np. w /lib choć jest w /usr/lib), co dosyć typowe w RedHat.


Też o tym myślałem i zrobiłem linki symboliczne z lib do lib/user:
lrwxrwxrwx 1 root root 23 mar 26 20:40 libclamav.so.5 -> /usr/lib/libclamav.so.5
lrwxrwxrwx 1 root root 32 mar 26 20:41 libclamunrar_iface.so.5 -> /usr/lib/libclamunrar_iface.so.5
lrwxrwxrwx 1 root root 26 mar 26 20:41 libclamunrar.so.5 -> /usr/lib/libclamunrar.so.5


Maciek_Rutecki napisał/a:
Dla pewności: instalacja z pakietów RPM?

tak ja podałem wyżej: rpm -Uhv clam*rpm
Wersja 0.42.2 tak samo zrobiłem i nie było żadnych problemów

Maciek_Rutecki napisał/a:
PS. Szczeciński AmprNet? :)

Tak jestem administratorem sieci Polskiej AmprNet 44.165.0.0/16 i światowej 44.0.0.0/8
_________________
Janusz Przybylski - SP1LOP
----------------------------------------------------------
Admin Polskiej Sieci AmprNet [44.165/16]
 
     
Maciek_Rutecki 
Administrator

JID: [email protected]
Pomógł: 39 razy
Dołączył: 07 Cze 2005
Posty: 2959
Wysłany: 2009-04-15, 18:05   

SP1LOP napisał/a:
libclamav.so.5 jest wymagany przez (zainstalowany) clamav-milter-0.94.2-1.el3.rf


Instalacji nowszego clamava (0.95) przeszkadza clamav-milter (0.94), gdyż ten nadal potrzebuje starszego libclamav.

Dawno już nie używałem dystrybucji opartych na RedHat, ale w pierwszej kolejności usuń clamav-milter (służy do sprawdzania poczty wysyłanej w sendmail i jeśli system to nie serwer, to jest zbędny, w przeciwnym wypadku jego też należy później zainstalować w nowszej wersji):

Kod:
rpm -e clamav-milter-0.94.2-1.el3.rf.rpm


(jeśli nie przekręciłem nazwy pakietu)

Potem już można spróbować zainstalować nowszego clamava (rpm -Uvh...), jeśli ponownie coś nie będzie chciał, to będzie trzeba usunąć kolejną skonfliktowaną paczkę. Urok zależności w systemach opartych na pakietach :-)
_________________
Maciek
http://www.maciek.unixy.pl
 
     
SP1LOP 
Emeryt-Inwalida


Dołączył: 25 Lis 2007
Posty: 9
  Wysłany: 2009-04-17, 12:02   

Maciek_Rutecki napisał/a:
Instalacji nowszego clamava (0.95) przeszkadza clamav-milter (0.94), gdyż ten nadal potrzebuje starszego libclamav.


Tu sie zgadzam ale dla wersji EL3 nie ma nowego clamav-milter jest ale dla wersji EL4

Maciek_Rutecki napisał/a:
Kod:
rpm -e clamav-milter-0.94.2-1.el3.rf.rpm

:lol: Małe sprostowanie dla czytających... przy usuwaniu nie podaje się rozszerzenia .rpm czyli:
Kod:
rpm -e clamav-milter-0.94.2-1.el3.rf.i386


Maciek_Rutecki napisał/a:
Potem już można spróbować zainstalować nowszego clamava (rpm -Uvh...), jeśli ponownie coś nie będzie chciał, to będzie trzeba usunąć kolejną skonfliktowaną paczkę. Urok zależności w systemach opartych na pakietach :-)


No niby tak ale bez clamav-miter nie skanuje przychodzącej poczty... :( Wiec odinstalowałem wersje 0.95 i zainstalowałem ponownie stara wersję 0.94.2-1, temat zostawiam na inny termin, i sprawdzę instalując wersję 0.95 dla EL3 + clamav-milter z wersje EL4, może zadziała i będzie działać nie wiem dam znać... :lol:
_________________
Janusz Przybylski - SP1LOP
----------------------------------------------------------
Admin Polskiej Sieci AmprNet [44.165/16]
Ostatnio zmieniony przez SP1LOP 2009-04-17, 12:04, w całości zmieniany 1 raz  
 
     
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group