Strona Główna Unixy.pl
Internetowe forum na temat systemów GNU/Linux Unix

FAQFAQ  SzukajSzukaj  UżytkownicyUżytkownicy  GrupyGrupy  StatystykiStatystyki
RejestracjaRejestracja  ZalogujZaloguj  DownloadDownload
 Ogłoszenie 
Strona korzysta z plików cookies w celu realizacji usług (logowanie do konta itp.). Możesz określić warunki przechowywania lub dostępu do plików cookies w Twojej przeglądarce.

Poprzedni temat «» Następny temat
[SOLVED] Problem z nagrywaniem płyt
Autor Wiadomość
sector 

Dołączył: 11 Sie 2009
Posty: 31
Wysłany: 2009-09-20, 13:52   [SOLVED] Problem z nagrywaniem płyt

Witam , mam problem z nagrywaniem płyt w Linuksie. Mam zainstalowany K3b i Gnomebaker i żaden mi nie chcę nagrać CD-RW. Tak wygląda /etc/fstab:
Kod:
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0
/dev/sr0             /media/sr0   auto    ro,user,noauto,unhide   0      0
/dev/cdrom             /media/cd   auto    ro,user,noauto,unhide   0      0
/dev/dvd               /media/dvd  auto    ro,user,noauto,unhide   0      0
#/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0
#/dev/fd0               /media/fl   auto    user,noauto             0      0
#/dev/sda1    /media/dysk    auto    rw,users,noauto    0    0
/dev/sda1 / ext4 defaults 0 1
/dev/sda6 /home ext4 defaults 0 1
/dev/sdb1 /mnt/usb vfat
umask=0,users,iocharset=iso8859-2,codepage=852,noauto,rw 0 0

A gdy odhacze " #/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto 0" to nie mogę uruchomić X-ów. Dodałem usera do grupy cdrom którą wpierw utworzyłem . Nie wiem czemu nie nagrywa tych płyt? Za pomoc z góry dzięki .
Ostatnio zmieniony przez sector 2009-09-21, 10:54, w całości zmieniany 4 razy  
 
     
scool 

JID: scool@jabberpl.org
Pomógł: 1 raz
Dołączył: 15 Lis 2005
Posty: 409
Wysłany: 2009-09-20, 14:18   

A taki np. K3b w konfiguracji swojej które urządzenie próbuje Ci wykryć jako nagrywające?
_________________
Każdy Polak oczywista, dba by w domu była Vista... Windows Seven always even :P

Co to jest KDE?? kde to po czesku "gdzie".

"...Z ręki obcej; źródła jego dawne serwery,
A numer jego będzie... 404."
 
     
sector 

Dołączył: 11 Sie 2009
Posty: 31
Wysłany: 2009-09-20, 15:15   

scool napisał/a:
A taki np. K3b w konfiguracji swojej które urządzenie próbuje Ci wykryć jako nagrywające?

Właśnie o to chodzi że nie wykrywa , w Burn Medium jest :
Kod:
Please insert an empty or appendable medium
Jak by jej nie wykrywało, ale np gdy wlożę płyte to thunar ją wykrywa i odczytuje co w niej jest?
Ostatnio zmieniony przez sector 2009-09-20, 15:16, w całości zmieniany 1 raz  
 
     
Maciek_Rutecki 
Administrator

JID: bc547@jabber.gda.pl
Pomógł: 39 razy
Dołączył: 07 Cze 2005
Posty: 2959
Wysłany: 2009-09-20, 18:12   

sector napisał/a:
/dev/sr0 /media/sr0 auto ro,user,noauto,unhide 0 0/dev/$
/dev/dvd /media/dvd auto ro,user,noauto,unhide 0 0


Co jest na koncu pierwszej linijki?
_________________
Maciek
http://www.maciek.unixy.pl
 
     
sector 

Dołączył: 11 Sie 2009
Posty: 31
Wysłany: 2009-09-20, 20:23   

Maciek_Rutecki napisał/a:
sector napisał/a:
/dev/sr0 /media/sr0 auto ro,user,noauto,unhide 0 0/dev/$
/dev/dvd /media/dvd auto ro,user,noauto,unhide 0 0


Co jest na koncu pierwszej linijki?


Poprawiłem ale nadal to samo :(
 
     
Maciek_Rutecki 
Administrator

JID: bc547@jabber.gda.pl
Pomógł: 39 razy
Dołączył: 07 Cze 2005
Posty: 2959
Wysłany: 2009-09-20, 20:38   

Masz dwa napędy optyczne?
_________________
Maciek
http://www.maciek.unixy.pl
 
     
sector 

Dołączył: 11 Sie 2009
Posty: 31
Wysłany: 2009-09-20, 22:03   

Maciek_Rutecki napisał/a:
Masz dwa napędy optyczne?

Jedna nagrywarka DVD tylko.
 
     
Maciek_Rutecki 
Administrator

JID: bc547@jabber.gda.pl
Pomógł: 39 razy
Dołączył: 07 Cze 2005
Posty: 2959
Wysłany: 2009-09-21, 06:51   

Co do fstab, jeśli już po scsi/sata to /dev/scd0 lub _istniejący_ symlink (np. /dev/dvd), a nie /dev/sr0. No i jak jeden napęd, to jeden wpis w /etc/fstab, a nie trzy.

Kod:
dmesg | grep -i dvd
_________________
Maciek
http://www.maciek.unixy.pl
Ostatnio zmieniony przez Maciek_Rutecki 2009-09-21, 06:52, w całości zmieniany 1 raz  
 
     
sector 

Dołączył: 11 Sie 2009
Posty: 31
Wysłany: 2009-09-21, 07:55   

Maciek_Rutecki napisał/a:
Co do fstab, jeśli już po scsi/sata to /dev/scd0 lub _istniejący_ symlink (np. /dev/dvd), a nie /dev/sr0. No i jak jeden napęd, to jeden wpis w /etc/fstab, a nie trzy.

Kod:
dmesg | grep -i dvd

Kod:
# dmesg | grep -i dvd
ata5.00: ATAPI: HL-DT-STDVD-RAM GH22LS30, 1.01, max UDMA/100
scsi 4:0:0:0: CD-ROM            HL-DT-ST DVD-RAM GH22LS30 1.01 PQ: 0 ANSI: 5
sr0: scsi3-mmc drive: 40x/48x writer dvd-ram cd/rw xa/form2 cdda tray

Po uruchomieniu z konsoli roota K3b nagrywa normalnie i jest wykryta nagrywarka. Lecz z konsoli usera już nie. utworzyłem grupy i dodałem do nich usera:
Kod:
$ groups
disk video audio users cdrom
Lecz po ponownym uruchomieniu nadal nie działa :( Może muszę nadać jakieś prawa wykonalnośći 0666?
Ostatnio zmieniony przez sector 2009-09-21, 07:56, w całości zmieniany 2 razy  
 
     
Maciek_Rutecki 
Administrator

JID: bc547@jabber.gda.pl
Pomógł: 39 razy
Dołączył: 07 Cze 2005
Posty: 2959
Wysłany: 2009-09-21, 08:14   

Dodawanie się do grupy disk to średnio dobry pomysł.

Kod:
ls -la /dev | grep sr0


Poprawiłeś fstab?
_________________
Maciek
http://www.maciek.unixy.pl
 
     
sector 

Dołączył: 11 Sie 2009
Posty: 31
Wysłany: 2009-09-21, 08:27   

Maciek_Rutecki napisał/a:
Dodawanie się do grupy disk to średnio dobry pomysł.

Kod:
ls -la /dev | grep sr0


Kod:
# ls -la /dev | grep sr0
lrwxrwxrwx  1 root root           3 09-21 08:25 scd0 -> sr0
brw-rw----  1 root optical  11,   0 09-21 08:25 sr0

Poprawiłeś fstab?

tak:
Kod:
# /etc/fstab: static file system information
#
# <file system>        <dir>         <type>    <options>          <dump> <pass>
none                   /dev/pts      devpts    defaults            0      0
none                   /dev/shm      tmpfs     defaults            0      0
#/dev/sr0             /media/sr0   auto    ro,user,noauto,unhide   0      0
#/dev/cdrom             /media/cd   auto    ro,user,noauto,unhide   0      0
/dev/dvd               /media/dvd  auto    ro,user,noauto,unhide   0      0
#/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0
#/dev/fd0               /media/fl   auto    user,noauto             0      0
#/dev/sda1    /media/dysk    auto    rw,users,noauto    0    0
/dev/sda1 / ext4 defaults 0 1
/dev/sda6 /home ext4 defaults 0 1
/dev/sdb1 /mnt/usb vfat
umask=0,users,iocharset=iso8859-2,codepage=852,noauto,rw 0 0

A co do dodania się do grupy disk to i tak nie pomogło, więc już zmieniłem jak było.
 
     
Maciek_Rutecki 
Administrator

JID: bc547@jabber.gda.pl
Pomógł: 39 razy
Dołączył: 07 Cze 2005
Posty: 2959
Wysłany: 2009-09-21, 08:51   

sector napisał/a:
brw-rw---- 1 root optical 11, 0 09-21 08:25 sr0


Z ciekawości; jaka to dystrybucja? Z /dev/ wynika, że musisz się dodać do grupy "optical".
_________________
Maciek
http://www.maciek.unixy.pl
 
     
sector 

Dołączył: 11 Sie 2009
Posty: 31
Wysłany: 2009-09-21, 08:59   

Maciek_Rutecki napisał/a:
sector napisał/a:
brw-rw---- 1 root optical 11, 0 09-21 08:25 sr0


Z ciekawości; jaka to dystrybucja? Z /dev/ wynika, że musisz się dodać do grupy "optical".

No już wpadłem na to i poradziłem sobie z problemem :) Dodałem polecenie
Kod:
chmod 0666 /dev/sr0


No i zbyt wczesna radość . Po ponownym uruchomieniu już nie nagrywa i nie wykrywa nagrywarki :(
Kod:
# ls -la /dev | grep sr0
lrwxrwxrwx  1 root root           3 09-21 10:17 scd0 -> sr0
brw-rw----  1 root optical  11,   0 09-21 10:17 sr0
Wydaję mi się obok roota powinien być wpis cdrom?
Ostatnio zmieniony przez sector 2009-09-21, 09:22, w całości zmieniany 1 raz  
 
     
Maciek_Rutecki 
Administrator

JID: bc547@jabber.gda.pl
Pomógł: 39 razy
Dołączył: 07 Cze 2005
Posty: 2959
Wysłany: 2009-09-21, 10:18   

sector napisał/a:
Wydaję mi się obok roota powinien być wpis cdrom?


To definiują regułki udev, możesz je zmienić. Jesteś w grupie optical?
_________________
Maciek
http://www.maciek.unixy.pl
 
     
sector 

Dołączył: 11 Sie 2009
Posty: 31
Wysłany: 2009-09-21, 10:53   

Maciek_Rutecki napisał/a:
sector napisał/a:
Wydaję mi się obok roota powinien być wpis cdrom?


To definiują regułki udev, możesz je zmienić. Jesteś w grupie optical?


Maciek_Rutecki dziękuję Ci bardzo , nie byłem w grupie optical już działa :) Pozdrawiam.
 
     
Wyświetl posty z ostatnich:   
Odpowiedz do tematu
Nie możesz pisać nowych tematów
Nie możesz odpowiadać w tematach
Nie możesz zmieniać swoich postów
Nie możesz usuwać swoich postów
Nie możesz głosować w ankietach
Nie możesz załączać plików na tym forum
Możesz ściągać załączniki na tym forum
Dodaj temat do Ulubionych
Wersja do druku

Skocz do:  

Powered by phpBB modified by Przemo © 2003 phpBB Group